Moon Software Forum
Moon Software Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 Discussion Forums
 Backup Magic
 Incremental Backups
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

marioguttman
Member

USA
4 Posts

Posted - 16 March 2003 :  02:31:57  Show Profile  Reply with Quote
I am testing the software before buying. I don't seem to be able to do what I want. I want to have two icons on my desktop. The first will do a full backup of all the sets to a folder with the date in its name. The second will do an incremental backup to a folder with the date in its name. The problem is that if I set "use archive attribute" off in the full backup, the the bit is not getting set so that when I start the first incremental backup it does a full the first time.

Is there a work around?

Thanks

Ahto/Moon Software
Developer

Estonia
1141 Posts

Posted - 16 March 2003 :  12:33:33  Show Profile  Visit Ahto/Moon Software's Homepage  Reply with Quote
You need to use the "Use archive attributes" option for both sets, otherwise the archive attribute is not reset after copying. Maybe a future version will provide special option for this so you can reset archive attribute even "Use archive attributes" option is not used.
Go to Top of Page

marioguttman
Member

USA
4 Posts

Posted - 22 March 2003 :  20:02:02  Show Profile  Reply with Quote
I really like your software and am planning to purchase it but I think your answer is wrong.

If I select to use the archive attribute with the full backup it won't perform a full backup.

Instead, what I am planning works pretty well. I have the attribute setting "off" on the full backup and "on" on the incremental one. This means that the first incremental backup is actually a full one but after that it only gets incremental changes. The incremental sets do not exactly align with the full ones but as long as I do an incremental backup just before a full one the misalignment will be small.

Mario

Go to Top of Page

Ahto/Moon Software
Developer

Estonia
1141 Posts

Posted - 23 March 2003 :  18:47:57  Show Profile  Visit Ahto/Moon Software's Homepage  Reply with Quote
quote:
If I select to use the archive attribute with the full backup it won't perform a full backup.


That is because files previously copied have no archive attribute set. If you manually set archive attribute of all source files and folders, it should work with full backup. If you don't set the attribute manually, it will not work. I did not think about this when I replied.

I think your situation can only be solved by adding new option "Clear archive attribute" that works also when "Use archive attributes" option is not selected.
Go to Top of Page

Ahto/Moon Software
Developer

Estonia
1141 Posts

Posted - 25 March 2003 :  20:42:00  Show Profile  Visit Ahto/Moon Software's Homepage  Reply with Quote
Updated version 1.6.2 is now available. It has new expert setting RemoveArchiveAttribFromSource. When this is set, the program will always clear archive attributes of source files. See "Expert Settings" topic in user's manual.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Moon Software Forum © Copyright 1996-2011 Moon Software Go To Top Of Page
Snitz Forums 2000